M Menu
b 0 Items s

SProblem with Converted Ford GTR (C3290)

Hi Everyone,

I wonder if anyone has any advice.  We have a Ford GTR (C3290) that was converted to digital (with a C7005 chip) for us by JRM a couple of years ago.  It worked fine to start with, but having recently started using it again the car is not working.

I’m ashamed to say that the Scalextric was not really used in 2017 due to other commitments.  However, we have recently started using the new ARC system and after a few teething problems, the track and all our cars are running ok apart from this particular GTR.  We have a number of both DPR and retro-fitted cars and all run fine.  I have had a look inside the car and there are no obvious broken wires or loose components, and the soldering all looks good.  When the car is placed on the track and the throttle pressed the lights come on so there is power getting to it, but it will not run.  If given a push it will reluctantly go but soon gives up and it does not respond to the throttle.  The braid is also good.

Can anyone offer any suggestions please?  Many thanks.

alan_west

26 posts

I would recommend you check the running gear - has the rear axle slipped out, are the gears locked for some reason? The running gear should all be smooth running. Worth a check. I run two off track tests to help establish cause of a problem the easiest is putting a 9v battery on the braids and everything should run well. Also, I have a short section of analogue track (20cm or so) that does the same thing but allows me to apply variable power. Sometimes the motors become 'stuck' - unusual on a standard scaley mabuchi motor. Running the motor on a test bed will help to clear it - don't do it on the digital track as the power drain may cause the chip to blow.

Thanks Alan. I have just tried the 9v battery test (with the chassis exposed) and the lights came on, but the motor did not run. However, with the battery still attached I gave the drive wheel nearest the gears a quick push/turn to see if the motor would unlock and after a couple of attempts it did run.  The problem is as soon as the power is removed and then reconnected, the motor again fails to run without another push/turn of the wheel.  I have tested it numerous times and unfortunately the situation is not improving.  The best I have had is three restarts without my help.

I guess this would seem to indicate a defective motor.  Do you perhaps have any suggestions for clearing the fault or should I be looking to replace the motor?  Many thanks.

Andy P.

1681 posts


Community Moderator

replacing the motor is likely the easiest way...

Thanks Andy. New motor it is then.

Please create an account or login to reply.

Forum Rules

  • The Scalextric Forum is intended for discussion of slot-car racing. Primarily, a place for newcomers to ask questions and seek assistance from like-minded individuals, the Scalextric Forum offers users the chance to join an active and friendly community.
  • Discussion of other slot-car brands is allowed, however, active promotion or advertising of our competitors is not permitted.
  • Please keep in mind that the Scalextric Forum is a publicly viewable space and you should never post personal information (including email addresses).
  • While every effort is made to contact you before any censorship, we reserve the right to amend or remove any content without explanation.
  • All customer service enquiries should be directed to Scalextric Customer Services.

Useful Links

Forum Guidelines



Membership Restricted Product