Store: Scalextric
Scalextric US English $
M Menu
b 0 Items s

SArc Air (many) issues


3 posts

Hello all,

We have just updated our large (12M) home layout from an old analogue powerbase to an Arc Air and we are now having a lot of problems.

The track is maintained in excellent condition, as are the braids on the cars.  We have a lot of cars and many different makes, all of which used to run fine on the old power base.

Now it is a very different story unfortunately.

All cars run fine when using the Arc Air power base only, without the app turned on.  But once the app is on, the trouble begins.

Not all of the cars will run at all, and some will run in fits and starts all over the track, and this is with all brands, Scalextric, Ninco, Pioneer, FlySLot etc.

It gets even worse if you try to run two cars at the same time, even with two reasonably low-drawing Scalextric cars.

Then if we try any of the race apps, it's completely useless.  If we do have two cars that run fine, we are lucky to get two laps in before the app stops due to powerbase overload.  And this is after over an hour of free practice runs without the app turned on and without any isses.

We have not been able to have one race with the app, which is defeating the whole purpose of buying the thing.  Can anyone offer any advice as to what mifght be causing this issue?  I was wondering if I need to upgrade the power supply?


798 posts

Hi Ausracer - welcome to the forum! 


That is a very frustrating - and strange - problem... Because everything is working fine without the app, I am pretty sure you do not need a power supply upgrade. Again, because everything is working fine without the app, I would think the cars, controllers and the track are all functioning correctly and are well maintained.


Because the problem starts when when you launch the app, my hunch would be to look at the app. ARC Air (and ARC Pro) actively control the power to the track via the app features. So a major glitch in the app install or a problem with device compatibility could cause the problem you describe. Compatibility is discussed here: - it can be really handy to try another device (particularly an Apple device on the list) to see if you can get your ARC Air working with the app.


If the cars have never worked with the app, I would try delete the app and then doing a fresh install from the Apple App Store, Google Play or the Amazon AppStore, depending what version of the app you are using. Try running the cars again. If that fixes it, great! If you still have a problem, but you notice any change (however small) try the delete / fresh install process again.


If you still have no luck after 3-4 delete / install attempts, the next step is to try the App Race Control (Legacy) app - this is the original version of the app and works very well with ARC Air. You will find it still available for Apple, Android and Amazon Fire devices.


If your cars did work for a while with the app, but don’t now, make sure you hard-stop the app and relaunch it every time you use it. The app can get glitchy without good housekeeping. I’ve written up more info, including some good housekeeping tips, for the ARC app here:


I hope that helps you getting your ARC Air powerbase working with the app - it really is a great set-up. If you need more help, please let us know the exact model of smart device you are using, plus the version of the operating system it is running. There is a small chance that the issue could be in the circuitry the app connects to in the powerbase and that would require a replacement - however it is important to try the app / device solutions first, otherwise you’ll end up with a new powerbase, but the same problem!



3 posts

Hi Woodcote, I really appreciate your reply.  I'm using an iPad Air with the latest OS install.  Today we ran the system without the app for over four hours (testing and running in some new cars) and it worked without any issues.  Then we wanted to race so tried a Quick Race and no luck, two laps in and the app just closed.  Opened the app again, start another Quick Race and not even one lap and the dreaded power base overload issue raised it's head and we could not run.  This is running two Scalextric 1963 mini coopers, which are not exactly high current drains.  We turned everything off for a few minutes (iPad, powerbase and hand controllers) and then rebooted and decided to try just using the Practice setting so at least we could get some lap times.  That worked well and we used it continuously for another 2 hours with only one annoying glitch - one track always had some low voltage going through it, not enough to move cars with magnets but probably enough not to do the cars much good if left for a while.  This did not spoil the racing as the hand throttles worked well, but the low valtage when stopped issue remained (always one track only and always the same track).  Tomorrow we will try downloading and using the lagacy app as you suggest and will advise how we go.

Andy P.

1707 posts

Community Moderator

Try deleting the APP completely and reinstalling. Sometimes there are issues when installing.

Also try the legacy app as woodcote suggested.

Also try different devices if possible. There is a pinned thread with dozens of compatible devices.

Rarely cars can cause interference if they have had the noise supressors (sometimes called ferrite men) removed .

Cars must have black guide blades to have te laps counted.


3 posts

Update; tried re-installing the App twice and also using the legacy app, results are better and the same between both.  We can now run races with all cars apart from Pioneer cars, they cause power base overload messages and then we have the phantom power on the single lane until we turn everything off and re-set.

Unfortunately I don't have any alternative devices to try with the app at this stage, so we will preservere with what we have until another device is available to see if it makes a difference.

Andy P.

1707 posts

Community Moderator

Some non-Hornby cars pull more amps than the power supply can handle.

I have heard of people using laptop power suplies up to 4 amps on ARC AIR with no problems but that does void warranty.

I don't have any pioneer cars so not sure what amps they pull or if it is possible to replace the motors.


798 posts

Hi Ausracer - glad the app problem seems to be at least partially fixed! The Apple devices seem to be pretty stable with ARC, so I wouldn't expect any difference - but it is always worth trying with another device, just to remove the device as a possible reason for your issues.


The 'phantom power' you describe is odd. Is that something that only happens with the app? And does it happen with both the new app and the legacy app? If it is an app thing, do you adjust the 'calibration' setting for different cars? The calibration sets the lowest speed that a car will move and is important for some of the power features, such as when fuel or tyres run out, incidents, weather changes, end of race etc etc. If the calibration is set too low for a specific car, there will be some power going to the track, but the car won't move. You may have already looked at this.


Two Pioneer cars should be fine with ARC Air - I have run them with my ARC air with no issues that I remember... The Pioneer motors use a little more power than a standard Scalextric motor, but not much. Overall, they require about the same power as a Scalextric car with the slim can FF motor. It is worth checking all the usual places in the car for a short circuit - braids, exposed wires touching, bare wires or components touching the motor can etc. It worries me that you say it is all Pioneer cars, rather than just one. How many have you tried?


Given that those two remaining issues are rather odd, let us know how you get on. It may be that the faulty app installation wasn't the only thing wrong...

Please create an account or login to reply.

Forum Rules

  • The Scalextric Forum is intended for discussion of slot-car racing. Primarily, a place for newcomers to ask questions and seek assistance from like-minded individuals, the Scalextric Forum offers users the chance to join an active and friendly community.
  • Discussion of other slot-car brands is allowed, however, active promotion or advertising of our competitors is not permitted.
  • Please keep in mind that the Scalextric Forum is a publicly viewable space and you should never post personal information (including email addresses).
  • While every effort is made to contact you before any censorship, we reserve the right to amend or remove any content without explanation.
  • All customer service enquiries should be directed to Scalextric Customer Services.

Useful Links

Forum Guidelines

Membership Restricted Product