Store: Scalextric
Scalextric US English $
M Menu
b 0 Items s

Dd213

All Posts

dd213

9 posts

I finally talked to one of the two gentlemen in tech yesterday and he was very apologetic and said they’ve been real busy and that TK is the man I need to talk to...they have only two techs one of which is the “train guy” for the entire US and he would personally give TK the message..we had fun at my exspense of course but it it what it is and I’m fine with that...the reason I haven’t talked to the professor is mostly because I’ve already rattled the poor mans ear off in the last two months and pretty soon he probably won’t take my calls anymore..lol no but seriously I jus wanted to talk to TK first and if he didn’t know he’d send me there if he thought the professor would anyway..hope that y’all don’t think I’m blaming the company or anyone for my dumb mistakes cause I’m truly not ...I jus get frustrated when I can’t do something especially something I should have no problem with...but I am getting older and it’s getting to the point my 11 yr old will be taking care of the tech stuff! Lol...you guys have been above and beyond with ideas and support and keep throwing ideas out there...thank you all again!

dd213

9 posts

Believe me I’ve considered it but unless I could find one for $20-30 I’ll have to be patient...I’ve managed to dump probably about $1500 plus selling my snowmobile  into this in a matter of 3-4 months time and if I have to ship I’m thinking that’s about what I’d have in costs but we’ll have to wait and see...still had absolutely no luck contacting anyone from Scalextric customer service...it’s really frustrating...really thought they would have great customer care and I’m all about giving the benefit of a doubt but I’ve never ever had a company so blatantly ignore my plights for help..pretty disappointed with them at the moment 

dd213

9 posts

Ya when I mess up I mess up good...I’ve been relentless today calling customer service..still nothing...not giving up!...got the ARC one pb hooked back up with drivers station and good ol reliable Professor Motor controllers all wired back up...I know I’m gonna have to send it in so just have to trying so we can get this ball rolling...just want my digital back...guess we’ll be slaves to the wires again...lol..on a possitive note we are back up and running again thanks again Dr.C!

dd213

9 posts

sure did Dr.C....the ARC Pro PB doesn't show up on any device Bluetooth...and hasn't since my screw up...tried several times with several devices apple and androi...if there was a way to connect to the PB other than BLE I could load firmware but as of yet I've had no luck

dd213

9 posts

Ok and thank you all for all the ideas and advice...I’m going to put my ARC One pb back on and rewire the drivers station and remove chips so we can at least play unt we get sorted out...jus wish there were a way to get the original firmware on via USB port but until I hear from scalextric we‘ll Have to go back to analog..thank you all again and will keep u posted on the issue 

dd213

9 posts

I built everything from the ground up in about 6 weeks and my son was very surprised come Xmas morning...well worth the money and effort

 

Admin edit: Image upload failed - please ensure you use one of the image uploaders.

dd213

9 posts

Yes it is Mr.Andy and I agree they can probably help me but I've been leaving messages on both gentlemans voicemails along with emails for the last week and a half to 2 weeks I've had the problem in fact that's why I've posted here..I've combed all the forums I could find just to make sure someone hasn't already had this issue so not to waste anyone's time. I've put so much money and energy into this so that my son and I have something we enjoy doing together while trapped in the house all winter. When I started all of this I could only hope he would take to it and we would have something to build on. There is a very limited amount of detailed information on the Internet for questions and or issues I've come across. Yes I'm new to this but I'm very mechanically inclined as well as tech savv in fact I'm a huge geek but I've struggled terribly with all of this and have even talked to Oliver at professor motor quite a few times and that's where most of the track PSU, 4 PM controllers and wiring came from not to mention the Slot it SCP-2 and O2 cartridge and chips I purchased from him...he's been a huge help at relieving some of my frustration...I know I screwed up with the firmware and I'm not even sure how...I'm just wanting to fix my screw up and get back to the fun part...racing slot cars with my boy

dd213

9 posts

I'm sorry yes nRf tools and I'm a newbie and dove into this head first. My thought behind this is to get my son who at 11 has a passion and knowledge of cars the jus amazes me into something other than video games. I started my journey into slot cars in October to get this for my son for Xmas and i have spent so many man hours on research building tables and track and wiring and more research...I built 3 big tables with about 120 ft of track( analog) and after Xmas we wanted digital so sold my sled and bought ARC Pro sunset speedway and frustration on the complete lack of detailed info on this hobby has set in...if it weren't for the addiction it's become now I would've give up ...sorry just thought I'd give you a heads up on my whole deal..so I wanted to upgrade controllers and still be wireless and the only option was Slot it...I've had it for a month now and I've been unable to get it to work with anything but one Slot it car with type A chip can't even get it to work with my two other 15b chipped cars..I went to slot it and thought I was getting the right firmware but it wasn't clear what was what so I guessed the one that said Horby and now nothing works including the bluetooth...my iPads iPhones nothing can detect it...I'm so frustrated and now it's stopped us dead in our tracks and my son is ready to kill me

dd213

9 posts

I bought a slot it Slot it SCP2 with O2 cartridge and updated my pb with a slot it packet and now its solid red and nothing works...i tried several times to flash it back scaley but when i try yo select device nothing shows up..no bt device shown anywhere...ive tried several times to talk to customer support but noone will call me back...my kid is about to murder me...plz help

Forum Rules

  • The Scalextric Forum is intended for discussion of slot-car racing. Primarily, a place for newcomers to ask questions and seek assistance from like-minded individuals, the Scalextric Forum offers users the chance to join an active and friendly community.
  • Discussion of other slot-car brands is allowed, however, active promotion or advertising of our competitors is not permitted.
  • Please keep in mind that the Scalextric Forum is a publicly viewable space and you should never post personal information (including email addresses).
  • While every effort is made to contact you before any censorship, we reserve the right to amend or remove any content without explanation.
  • All customer service enquiries should be directed to Scalextric Customer Services.

Useful Links

Forum Guidelines


Membership Restricted Product